[UVA10282]Babelfish - 為什麼Map的Key不能用Char?

Posted by John on 2016-02-21
Words 373 and Reading Time 2 Minutes
Viewed Times

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as ‘eh’.

Sample Input

dog ogday cat atcay pig igpay froot ootfray loops oopslay
atcay ittenkay oopslay

Sample Output

cat eh loops

題意: 查字典,翻出原本的英文

想法: 用MAP很簡單就可以達成,但這題我卡了很久,原因在於我用了char 而不是string,所以資料根本不會被insert到map中,如果一定要用的話就要用const char,原因可以看一下這些地方:

後來把char* 改成string就AC了。

歐對了,還有一個小地方是,find是找map對應的key值,所以存的時候順序要對。

#include <cstdio> 
#include <cstdlib>
#include <map>
using namespace std;
int main() {
map d;
char s[25],a[11],b[11];
while(gets(s) && s[0] != '\0') {
sscanf(s,"%s %s",a,b);
d.insert(pair(b,a));
}
while(gets(s)) {
map::iterator it; it = d.find(s);
if(it == d.end()) printf("eh\n");
else printf("%s\n",it->second.c_str());
}
return 0;
}

>