星期五。見面

程式 | 學習 | 日記 | 玩樂

    [論文速速讀]系列文章介紹

前言

論文速速讀系列是從今年四月開始,我開始寫一些論文的中文讀書筆記,還記得第一篇是[論文速速讀]ReZero is All You Need: Fast Convergence at Large Depth,之後發現儘管自己已經陸續產出了幾篇文章,可是好像都沒正式的跟大家介紹這系列文章的由來xD

所以這篇文章就是來講講這系列文章到底是什麼,以及我會和會想寫這些文章。

論文速速讀系列是什麼?

由於在AI領域每年總是有一些非常重大的突破和應用,如果跟不上潮流很有可能就會錯失許多機會。例如,對NLP領域熟悉的話你一定聽過2013年的word2vec、2014年開始流行的attention、2018年的Bert…這些很有名的技術。

還記得Bert剛出的時候我好像剛進碩士實驗室,當時只知道這個技術屌打了當時一堆NLP的研究,但我想也想不到兩年後Bert已經造成如此大的影響力,一堆基於Bert的變形應用在各大領域上都取得了非常優異的結果。

因此,我想要藉由這系列的文章讓自己能夠更加快速的了解AI的新技術和研究,同時逼迫自己看論文xD

繼續閱讀

    [課程筆記]課程筆記系列總覽

本文記錄了自己在上課時所記錄的一些課程筆記,可以透過這邊文章連結到所有以往發過的課程筆記文章。

繼續閱讀

[UVA476]Points in Figures: Rectangles

Given a list of rectangles and a list of points in the x-y plane, determine for each point which figures (if any) contain the point.

Input

There will be n( tex2html_wrap_inline220 ) rectangles descriptions, one per line. The first character will designate the type of figure (``r’’ for rectangle). This character will be followed by four real values designating the x-y coordinates of the upper left and lower right corners. The end of the list will be signalled by a line containing an asterisk in column one. The remaining lines will contain the x-y coordinates, one per line, of the points to be tested. The end of this list will be indicated by a point with coordinates 9999.9 9999.9; these values should not be included in the output. Points coinciding with a figure border are not considered inside.

Output

For each point to be tested, write a message of the form:

Point i is contained in figure j

for each figure that contains that point. If the point is not contained in any figure, write a message of the form:

Point i is not contained in any figure

Points and figures should be numbered in the order in which they appear in the input.

Sample Input

繼續閱讀

[PHP]incomplete class解決方法

近日再寫PHP的時候,再參考一些SESSION使用資料的程式碼時會出現__PHP_Incomplete_Class的問題:

我寫了一個Class,然後用SESSION去儲存這個Class,但當我下次取他的時候就會造成這個錯誤。

這個錯誤跟寫法與設定有關係,上網GOOGLE後發現這個造成這個ERROR的原因是因為PHP是直譯式的,所以如果我在讀取SESSION前沒有先去定義Class時程式就會出錯,因為他不知道這是個物件。

網路上的參考解決辦法是

繼續閱讀

[UVA490]Rotating Sentences

In ``Rotating Sentences,’’ you are asked to rotate a series of input sentences 90 degrees clockwise. So instead of displaying the input sentences from left to right and top to bottom, your program will display them from top to bottom and right to left.

Input and Output

As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100 characters long. Legal characters include: newline, space, any punctuation characters, digits, and lower case or upper case English letters. (NOTE: Tabs are not legal characters.) The output of the program should have the last sentence printed out vertically in the leftmost column; the first sentence of the input would subsequently end up at the rightmost column.

Sample Input

Rene Decartes once said,
"I think, therefore I am."

Sample Output

"R
Ie
n
te
h
iD
ne
kc
,a
r
tt
he
es
r
eo
fn
oc
re
e
s
Ia
i
ad
m,
.
"

想法:

蠻簡單的題目,改變一下輸出順序即可。要注意的是如果前一行的長度比後面的句子短,在倒轉後會造成缺少空白的情形,所以要隨時記錄最大長度的句子,並把所有比他小的句子都補齊空白。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int main()
{
char s[101][101];
int i = 0;
int len = 0;
memset(s,0,sizeof(s));
while (gets(s[i])) {
len = len < strlen(s[i]) ? strlen(s[i]) : len;
i++;
}
for(int j = 0 ; j < i ; ++j) {
for(int k = strlen(s[j]) ; k < len ; ++k) {
s[j][k] = ' ';
}
}
for(int k = 0 ; k < len ; ++k) {
for(int j = i-1 ; j >= 0 ; --j) {
printf("%c",s[j][k]);
}
printf("\n");
}
return 0;
}
繼續閱讀

Win10解決開始功能表無法開啟的問題

就在今天開啟電腦發現我的開始功能表下面那一列都無法開啟,只能在點右鍵會有反應…

這沒道理阿???我昨天關機前明明就好好的,想了想有可能是win10強制更新的造成的BUG,上網GOOGLE(本來連上網都沒辦法…因為還要去設定連線,好險電腦有記錄我手機的WIFI)了許多方法都沒有效果…

後來把更新改回上一次版本,然後重新開機就恢復了!!以下是我的方法:

繼續閱讀

NCPC複賽

初賽完兩個禮拜就是複賽了,兩個禮拜其實也沒很長,所以這中間也沒什麼特別的準備就上了。比賽地點在中山大學,和隊友們從學校搭捷運去西子灣轉公車,一下車就看到以前暑訓的神人室友,所以就一起在中山裡面找路了(因為沒有人知道路……)。 12079338_1194183207264595_3732027757611351140_n

繼續閱讀

NCPC初賽

參加Ncpc的起源要從大一的暑訓開始,在那裏遇到的人幾乎都是專門參加程式競賽的,而回來後學校教授也推薦我們組一隊去比比看,於是就和兩位同年級的開始著手準備了。 說是準備,其實也是把去年的初賽題目拿來寫一遍而已,經過一個禮拜的折磨好不容易寫完了五題,但那都是寫寫停停、上網找找Liberary而完成的就是了。順帶一提,在暑訓期間的高手、神人們在參賽名單上全部都出現了。

12109223_916108731805553_6288868111926439114_n

繼續閱讀

>